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KBAlertz.com: Exchange services cannot be started, and event ID 7024 is logged after you install Symantec Mail Security on a Windows Server 2008-based computer that is running Exchange Server 2007

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Microsoft Knowledge Base Article

This article contents is Microsoft Copyrighted material.
©2005-©2007 Microsoft Corporation. All rights reserved. Terms of Use | Trademarks

Exchange services cannot be started, and event ID 7024 is logged after you install Symantec Mail Security on a Windows Server 2008-based computer that is running Exchange Server 2007

Article ID:954204
Last Review:June 24, 2008
Revision:1.0

SYMPTOMS

After you install Symantec Mail Security on a Windows Server 2008-based computer that is running Microsoft Exchange Server 2007, Exchange services cannot be started. Additionally, the Exchange Active Directory Topology Service fails, and the following event error is logged in the System log:

Log Name: System
Source: Service Control Manager
Event ID: 7024
Task Category: None
Level: Error
Keywords: Classic
Description:
The Microsoft Exchange Active Directory Topology Service service terminated with service-specific error 2147942414 (0x8007000E).

Note When this issue occurs, you cannot resolve this issue by uninstalling Symantec Mail Security. You may also notice that you cannot clear the Application log events.

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CAUSE

This issue occurs because Symantec Mail Security modifies the following registry subkey to write event logs only for Symantec applications:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Eventlog\Application\CustomSD
Therefore, when Exchange services tries to log events in the event log, Exchange services receives an "access denied" error message, and Exchange services cannot be started.

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RESOLUTION

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 (http://kbalertz.com/Feedback.aspx?kbNumber=322756/) How to back up and restore the registry in Windows
To resolve this issue, follow these steps:
1.Click Start, click Run, type regedit, and then click OK.
2.Locate and then right-click the following registry subkey:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Eventlog\Application
Notice that there is a value for the CustomSD registry entry. This value resembles the following value:
"O:BAG:DUD:(A;;CC;;;S-1-5-21-1564639177-1417944463-942302423-13664)(A;;CC;;;S-1-5-21-1564639177-1417944463-942302423-13665)"
3.Right-click the CustomSD entry, and then click Delete.
4.Restart the computer.

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MORE INFORMATION

For more information about the CustomSD registry subkey, click the following article number to view the article in the Microsoft Knowledge Base:
323076 (http://kbalertz.com/Feedback.aspx?kbNumber=323076/) How to set event log security locally or by using Group Policy in Windows Server 2003
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

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REFERENCES

For more information, visit the following Symantec Web sites:
http://service1.symantec.com/support/ent-gate.nsf/854fa02b4f5013678825731a007d06af/b594607c46cde6f280257372003cb3f7?OpenDocument (http://service1.symantec.com/support/ent-gate.nsf/854fa02b4f5013678825731a007d06af/b594607c46cde6f280257372003cb3f7?OpenDocument)
http://service1.symantec.com/support/ent-gate.nsf/854fa02b4f5013678825731a007d06af/18e2d707a1bf85068825738600629e24?OpenDocument (http://service1.symantec.com/support/ent-gate.nsf/854fa02b4f5013678825731a007d06af/18e2d707a1bf85068825738600629e24?OpenDocument)
Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

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APPLIES TO
•Microsoft Exchange Server 2007 Standard Edition
•Microsoft Exchange Server 2007 Enterprise Edition
•Microsoft Exchange Server 2007 Service Pack 1

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Keywords: 
kbexpertiseinter kbtshoot kbprb KB954204

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